Title
#users-public
c

cl

10/19/2022, 1:20 PM
Hi, Our build environment is jdk8, but we support java8,11,17. ILP java client library comes with jdk8 and non-jdk8 version. Are these 2 compatible?, Can I ship non-jdk8 only? Or, I need to let installer to determine Java version and land the jdk8 or non-jdk8 jar file?
Jaromir Hamala

Jaromir Hamala

10/20/2022, 12:43 PM
Hello, unfortunately they are not compatible. -jdk8 does not work on JDK 9 and newer. the regular JAR (non-jdk8) does not work on JDK 8.
c

cl

10/20/2022, 1:18 PM
Thanks for clarification.