Title
#users-public
r

Rutam Prita Mishra

10/13/2022, 10:03 AM
Hello there, I am just getting started with QuestDB. So, I have a few silly questions here regarding the initial setup. Would love some answers to it. • I passed all the parameters to install the questdb service on Windows like this-
questdb.exe install -d C:\Windows\System32\qdbroot -f -j JAVA_HOME -t questdbdemo
. Now do I need to pass these parameters again when I do a
questdb.exe start
or is it sufficient if I start it with the tag
questdb.exe -t questdbdemo
and it starts with the installed configuration? • Secondly, does anything change w.r.t. to the Web Console when we have a tag for the QuestDB service, or it will be available at
localhost:9000
all the time? How to know which service web UI I am currently working on? • Also, is there a way to check if the service has picked up the right JAVA path?
Pei

Pei

10/13/2022, 12:39 PM
Hi RPM, welcome. We’ll get back soon! (sorry, don’t have windows on my side now)
r

Rutam Prita Mishra

10/13/2022, 12:45 PM
Okay thanks.
Alex Pelagenko

Alex Pelagenko

10/13/2022, 1:17 PM
If you instal it as service I think you start and stop the service
1:18 PM
net start "questdbdemo"
1:20 PM
All services will use port 9000 unless you change it in
server.conf
. You will not be able to run multiple of them at the same time unless they use different ports.
1:21 PM
do you really need to run multiple services? it’s kind of an advanced topic
r

Rutam Prita Mishra

10/13/2022, 1:21 PM
No I don't need to. I was just confused as to how will this scenario be handled.
1:22 PM
I just need one service running. And any way to check it picked up the correct Java.exe.
Bolek Ziobrowski

Bolek Ziobrowski

10/14/2022, 6:43 AM
Hi @Rutam Prita Mishra . You can check java path by looking at
Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\QuestDB[tag]\ImagePath
in windows registery editor .
r

Rutam Prita Mishra

10/14/2022, 7:04 AM
Okay so I was trying to connect my local QuestDB service with MindsDB Cloud. I tunnelled the tcp 8812 port using Ngrok and passed the default username
admin
and password
quest
. The query got executed successfully but I was not able to find the tables in the MindsDB UI. Also there was a parameter
public: true
which was failing the query. So, I had removed it. I will check with MindsDB once again, but do let me know if I doind something wrong from QuestDB's end. I had imported a CSV file in my local instance and was able to see the table in the Web UI.
Alex Pelagenko

Alex Pelagenko

10/14/2022, 8:04 AM
QuestDB is not postrges replacement, many tools rely on certain functionality only postrges has